Sunday, August 29, 2010

Installing Campsite on Xampp

I am using Linux Mint 9 as my desktop operating system. I want to try new release of Campsite 3.4.2. Campsite is well known as free and open platform for publishing newspaper or magazine online. The website is here.

I am using Xampp for Linux 1.7.3a. It can be downloaded at ApacheFriends Site.
To install Xampp, use terminal and go to directory where you place your xampp-linux-1.7.3a.tar.gz file. Run the command "sudo tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt". It will prompt you to input your root password.To start Xampp, from terminal run this command "sudo /opt/lampp/lampp start"

I download Campsite 3.4.2 from Sourceforge, extract it into /opt/lampp/htdocs/campsite. As a root from terminal, I change the owner of campsite folder and all the file in it to "nobody", using command "chown -R nobody /opt/lampp/htdocs/campsite/". Then I change Group of campsite folder and all file inside it to "root" using command "chgrp -R root /opt/lampp/htdocs/campsite/".

From firefox browser, I launch "http://localhost/campsite" and install wizard is displayed. The install wizard will first check the server requrement. And unfortunately, Xammp package not included APC PHP cache extension that needed by Campsite 3.4.2, so the install wizard can not continue. I have to install APC PHP cache first. But how?..... Asking google, I found a blog that cover this issue.

To install APC PHP cache on Xampp Package, I follow all the instruction:

Add /opt/lampp/bin to your PATH using command line as a root from terminal "export PATH=$PATH:/opt/lampp/bin".
Download and install XAMPP Development Package.
Download APC version 3.1.4. from http://pecl.php.net/package/APC
From terminal as a root, extract APC-3.1.4.tgz and go into APC-3.1.4 directory then run this command "/opt/lampp/bin/phpize". This command give me an error, since my Linux Mint 9 does not have autoconf installed.
Then I install autoconf from Mint Menu >> Package Manager.
I run "/opt/lampp/bin/phpize" again and it works.
Then run this command "./configure --with-php-config=/opt/lampp/bin/php-config".
After that I run "make" and then "make install" command.
Then using Gedit text editor, I edit Edit /opt/lampp/etc/php.ini file and add the following lines:
extension="apc.so"
[APC]
apc.enabled = 1
apc.slam_defense = Off
apc.write_lock = 1
apc.enable_cli = 1
apc.shm_segments = 1
apc.max_file_size = 10M
apc.stat = 1

After All I restart Apache by issuing: "/opt/lampp/lampp restart"

To make sure APC got installed, I run this command from terminal as a root: "/opt/lampp/bin/php -m", and I see APC is in the list.

Then I go back again to Campsite Install Wizard. I follow all the instruction and it installed already.

Thursday, August 12, 2010

Ebook from Amazon

Need Ebook to learn something new to you.
Go to amazon and find a good one